0%

北大 acm 2140 Herd Sums 解题报告

Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 9629 Accepted: 5758

Description

The cows in farmer John’s herd are numbered and branded with consecutive integers from 1 to N (1 <= N <= 10,000,000). When the cows come to the barn for milking, they always come in sequential order from 1 to N.

Farmer John, who majored in mathematics in college and loves numbers, often looks for patterns. He has noticed that when he has exactly 15 cows in his herd, there are precisely four ways that the numbers on any set of one or more consecutive cows can add up to 15 (the same as the total number of cows). They are: 15, 7+8, 4+5+6, and 1+2+3+4+5.

When the number of cows in the herd is 10, the number of ways he can sum consecutive cows and get 10 drops to 2: namely 1+2+3+4 and 10.

Write a program that will compute the number of ways farmer John can sum the numbers on consecutive cows to equal N. Do not use precomputation to solve this problem.

Input
  • Line 1: A single integer: N
Output
  • Line 1: A single integer that is the number of ways consecutive cow brands can sum to N.
Sample Input

15

Sample Output

4

题意:找出count种连续的几个数字,使其相加的总和等于N方法: 使用数学中的前n项和公式na1+n(n-1)d/2 其中n为代码中的i,a1为代码中的j,公差为1;

代码
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
#include <iostream>

using namespace std;

int main()
{
int n,sum,i,j,count;

while(cin>>n)
{
count=1;

for(i=2;i<=n/2;i++)
for(j=1;j<=n/i;j++)
{
sum=i*j+i*(i-1)/2;
if(sum==n) count++;
if(sum>n) break;
}

cout<<count<<endl;
}

return 0;
}
谢谢您的打赏,我的大英雄 ^_^
Thank you for your generosity, my big hero ^_^

更多内容请关注公众号「西小玛」