0%

北大 acm 3096 Surprising Strings 解题报8

Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 2414 Accepted: 1632

Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the “Puzzling Adventures” column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBGXEEAABAABAAABBBCBABCC*

Sample Output

ZGBG is surprising.X is surprising.EE is surprising.AAB is surprising.AABA is surprising.AABB is NOT surprising.BCBABCC is NOT surprising.

题意:对输入的字符串,两个字符串从间隔为0到字符串长度中取出两个字符,然后对后面以相同的距离的字符串比较如果相等的 则输出is NOT surprising,如果全部都不相等则输出is surprising 此题用暴力法可以解决

代码
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
#include <iostream>

using namespace std;

int check(char s[],char to[],int number,int f)
{
int i,len=strlen(s);

for(i=f;i<len-number;i++)
{
if(s[i]==to[0]&&s[i+number]==to[1])
return 0;
}
return 1;
}

int main()
{
char str[100],a[2],is;
int i,j,len;

while (cin>>str&&strcmp(str,"*")!=0)
{
is=1;
len=strlen(str);

for(i=1;i<len;i++)
{
j=0;
while(j<len)
{
a[0]=str[j];
a[1]=str[j+i];

if(check(str,a,i,j+1)==0)
{
cout<<str<<" is NOT surprising."<<endl;
is=0;
break;
}

j++;
}
if(is==0) break;
}
if(is==1)
cout<<str<<" is surprising."<<endl;
}
return 0;
}
谢谢您的打赏,我的大英雄 ^_^
Thank you for your generosity, my big hero ^_^

更多内容请关注公众号「西小玛」