0%

北大 acm 2013 Symmetric Order 解题报告

Time Limit: 1000MS Memory Limit: 30000K Total Submissions: 6740 Accepted: 4180

Description

In your job at Albatross Circus Management (yes, it’s run by a bunch of clowns), you have just finished writing a program whose output is a list of names in nondescending order by length (so that each name is at least as long as the one preceding it). However, your boss does not like the way the output looks, and instead wants the output to appear more symmetric, with the shorter strings at the top and bottom and the longer strings in the middle. His rule is that each pair of names belongs on opposite ends of the list, and the first name in the pair is always in the top part of the list. In the first example set below, Bo and Pat are the first pair, Jean and Kevin the second pair, etc.

Input

The input consists of one or more sets of strings, followed by a final line containing only the value 0. Each set starts with a line containing an integer, n, which is the number of strings in the set, followed by n strings, one per line, sorted in nondescending order by length. None of the strings contain spaces. There is at least one and no more than 15 strings per set. Each string is at most 25 characters long.

Output

For each input set print “SET n” on a line, where n starts at 1, followed by the output set as shown in the sample output.

Sample Input

7BoPatJeanKevinClaudeWilliamMarybeth6JimBenZoeJoeyFrederickAnnabelle5JohnBillFranStanCece0

Sample Output

SET 1BoJeanClaudeMarybethWilliamKevinPatSET 2JimZoeFrederickAnnabelleJoeyBenSET 3JohnFranCeceStanBill

题意:把按长度排序的名字按长度对称的顺序输出水题

代码
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
#include<iostream>

using namespace std;

int main()
{
char str[100][100];
int n,i,head,tail,num=1;

while(cin>>n&&n)
{
head=0;
tail=n-1;

for(i=0;i<n;i++)
{
if(i%2==0)
cin>>str[head++];
else
cin>>str[tail--];
}

cout<<"SET "<<num++<<endl;

for(i=0;i<n;i++)
cout<<str[i]<<endl;
}
return 0;
}
谢谢您的打赏,我的大英雄 ^_^
Thank you for your generosity, my big hero ^_^

更多内容请关注公众号「西小玛」