0%

北大 acm 1936 All in All 解题报告

Time Limit: 1000MS Memory Limit: 30000K Total Submissions: 13776 Accepted: 5453

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output “Yes”, if s is a subsequence of t,otherwise output “No”.

Sample Input

sequence subsequenceperson compressionVERDI vivaVittorioEmanueleReDiItaliacaseDoesMatter CaseDoesMatter

Sample Output

YesNoYesNo

题意:判断后面的字符串是否通过前面的字符串随机插入字符发展而来 水题:要注意序号要相同不可倒置

代码如下

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
#include <iostream>

using namespace std;

int main()
{
char from[100000],to[100000];
int i,j,len1,len2;

while(scanf("%s%s",from,to)!=-1)
{
len1=strlen(from);
len2=strlen(to);
i=0;
if(len1>len2)
{
cout<<"No"<<endl;continue;
}

for(j=0;j<len2;j++)
if(from[i]==to[j]) i++;

if(i==len1)
cout<<"Yes"<<endl;
else
cout<<"No"<<endl;
}

return 0;
}
谢谢您的打赏,我的大英雄 ^_^
Thank you for your generosity, my big hero ^_^

更多内容请关注公众号「西小玛」