0%

北大 acm 1519 Digital Roots 解题报告

Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 16232 Accepted: 5401

Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24390

Sample Output

63

思路:要用字符串输入,数组保存

代码如下

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
#include <iostream>

using namespace std;

int getSum(long num[],int n)
{
long sum=0,i;
for(i=0;i<n;i++)
sum+=num[i];
return sum;
}

int main()
{
char str[1000];
long num[1000],sum,i;

while(cin>>str&&strcmp(str,"0")!=0)
{
i=0;

while(str[i]!='\0')
num[i]=str[i++]-'0';

sum=getSum(num,i);

while(sum>=10)
{
i=0;
while(sum>=10)
{
num[i++]=sum%10;
sum/=10;
}
num[i++]=sum;
sum=getSum(num,i);
}

cout<<sum<<endl;
}
return 0;
}
谢谢您的打赏,我的大英雄 ^_^
Thank you for your generosity, my big hero ^_^

更多内容请关注公众号「西小玛」