0%

北大acm 1012 Joseph 解题报告

Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 25710 Accepted: 9607

Description

The Joseph’s problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input

340

Sample Output

530

题目大意为按某个数字循环杀死一个人,前面k个都是好人,后面k个均为坏人,当循环数m为哪个数时使得后面k个坏人比前面k个好人先被杀死

代码如下

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
////总结公式要杀死的号码为前一个号码减1   (previous-1)+k%peoplenumber k为循环数    peoplenumber为剩余的人数
#include <iostream>

using namespace std;//结果需要保存在一个数组里,如果遇到重复的数字则可以直接输出

int get(int k,int n)
{
int i,s=k/2,t=0;
i=n%k;
if(i==0) i=k; //注意i算出来为0的情况
while(k)
{
if(i<=s&&t<s) return 0;
if(i<=s&&t>=s) return 1;

t++;
k--;
i=i-1+n%k;
if(i>k) i=i-k;
}
return 1;
}

int main()
{
int k,i,j,a[14]={0};
freopen("t.txt","rt",stdin);
while(cin>>k&&k!=0)
{
if(a[k]!=0) {cout<<a[k]<<endl;continue;}
if(k==1) { cout<<2<<endl;a[k]=2;continue;}
k*=2;
for(i=1+k/2;;i+=k)
{
for(j=0;j<k/2;j++)
if(get(k,i+j)==1)
{
cout<<i+j<<endl;
a[k/2]=i+j;
j=0;
break;
}
if(j==0) break;
}
}
return 0;
}
谢谢您的打赏,我的大英雄 ^_^
Thank you for your generosity, my big hero ^_^

更多内容请关注公众号「西小玛」