0%

北大 acm 1028 Web Navigation 解题报告

Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 13047 Accepted: 5735

Description

Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this.
The following commands need to be supported:
BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored.
FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored.
VISIT : Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied.
QUIT: Quit the browser.
Assume that the browser initially loads the web page at the URL http://www.acm.org/

Input

Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.

Output

For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print “Ignored”. The output for each command should be printed on its own line. No output is produced for the QUIT command.

Sample Input

VISIT
http://acm.ashland.edu/
VISIT
http://acm.baylor.edu/acmicpc/
BACK
BACK
BACK
FORWARD
VISIT
http://www.ibm.com/
BACK
BACK
FORWARD
FORWARD
FORWARD
QUIT

Sample Output

http://acm.ashland.edu/
http://acm.baylor.edu/acmicpc/
http://acm.ashland.edu/
http://www.acm.org/Ignored
http://acm.ashland.edu/
http://www.ibm.com/
http://acm.ashland.edu/
http://www.acm.org/
http://acm.ashland.edu/
http://www.ibm.com/Ignored

此题乃水题没有技巧可言,只要熟悉用IE的人都懂这个原理,就是页面的向前,向后,访问。

代码如下

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
#include <iostream>

using namespace std;

int main()
{
char order[4][10]={"VISIT","BACK","FORWARD","QUIT"},command[10];
char URL[1000][1000];
int allpage=0,currentpage=0;

sprintf(URL[0],"http://www.acm.org/");

freopen("t.txt","rt",stdin);

while(cin>>command&&strcmp(command,order[3])!=0)
{
if(strcmp(command,order[0])==0)
{
cin>>URL[++currentpage];
allpage=currentpage;
cout<<URL[currentpage]<<endl;
}
if(strcmp(command,order[1])==0)
{
if(currentpage==0) {cout<<"Ignored"<<endl;continue;}
currentpage--;
cout<<URL[currentpage]<<endl;
}
if(strcmp(command,order[2])==0)
{
if(currentpage==allpage) {cout<<"Ignored"<<endl;continue;}
currentpage++;
cout<<URL[currentpage]<<endl;
}
}
return 0;
}
谢谢您的打赏,我的大英雄 ^_^
Thank you for your generosity, my big hero ^_^

更多内容请关注公众号「西小玛」