0%

北大acm DNA Sorting解题报告

Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 39035 Accepted: 15135

Description

One measure of unsortedness in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence DAABEC, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence AACEDGG has only one inversion (E and D)—it is nearly sorted—while the sequence ZWQM has 6 inversions (it is as unsorted as can be—exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of sortedness, from most sorted to least sorted. All the strings are of the same length.
Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output

Output the list of input strings, arranged from most sorted to least sorted. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6AACATGAAGGTTTTGGCCAATTTGGCCAAAGATCAGATTTCCCGGGGGGAATCGATGCAT

Sample Output

CCCGGGGGGAAACATGAAGGGATCAGATTTATCGATGCATTTTTGGCCAATTTGGCCAAA

采用暴力对输入的数据逐一和后面的相比若小于该字母则加1,然后再对字符串排序输出

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
#include <iostream>        //暴力解决
#include <string>

using namespace std;

int main()
{
int n,m,i,j,k,sum[101]={0};
char str[101][52],p[52];
freopen("t.txt","rt",stdin);
while(cin>>n>>m)
{
for(i=0;i<m;i++)
{
cin>>str[i];
for(j=0;j<n-1;j++)
for(k=j+1;k<n;k++)
if(str[i][k]<str[i][j]) sum[i]++;
}

for(i=0;i<m-1;i++)
for(j=i+1;j<m;j++)
if(sum[i]>sum[j])
{
strcpy(p,str[i]);
strcpy(str[i],str[j]);
strcpy(str[j],p);
k=sum[i];
sum[i]=sum[j];
sum[j]=k;
}

for(i=0;i<m;i++)
cout<<str[i]<<endl;
}
return 0;
}

谢谢您的打赏,我的大英雄 ^_^
Thank you for your generosity, my big hero ^_^

更多内容请关注公众号「西小玛」