0%

北大 acm 2109 Power of Cryptography 解题报告

Time Limit: 1000MS Memory Limit: 30000K Total Submissions: 6666 Accepted: 3585

Description

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest.
This problem involves the efficient computation of integer roots of numbers.
Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the nth. power, for an integer k (this integer is what your program must find).

Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10101 and there exists an integer k, 1<=k<=109 such that kn = p.

Output

For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.

Sample Input

2 163 277 4357186184021382204544

Sample Output

431234

题意:找到一个k使得n的k次方和p相等。虽说此题为水题但要了解double的精度和范围,开始一直WA看了discuss才知道原来double能够表示的范围为10^101,很神奇,差点用大数做

代码
1
2
3
4
5
6
7
8
9
10
11
12
13
14
#include <iostream>
#include <cmath>

using namespace std;

int main()
{
double p, n,k;
while(scanf("%lf %lf",&n,&p)==2)
{
printf("%.0lf\n",pow(p,1/n));
}
return 0;
}
谢谢您的打赏,我的大英雄 ^_^
Thank you for your generosity, my big hero ^_^

更多内容请关注公众号「西小玛」