0%

北大 acm 2909 Goldbach's Conjecture 解题报告

Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 5675 Accepted: 3377

Description

For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that

n = p1 + p2

This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. There can be many such numbers. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.

Input

An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 215. The end of the input is indicated by a number 0.

Output

Each output line should contain an integer number. No other characters should appear in the output.

Sample Input

610120

Sample Output

121

题意:输入任意一个大于4的偶数n,问有几个素数对使得两个素数的和等于n思路:(2、n-2),(3、n-3),(5、n-5),(7,n-7)……..对里面的元素进行判断,如果两个都是素数则条件符合,反之不符合

代码
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
#include <iostream>
#include <math.h>

using namespace std;

int isSushu(long n) //判断是否素数,是返回1,否返回0
{
int i;

for(i=2;i<=sqrt((double)n);i++)
if(n%i==0)
return 0;

return 1;
}

int main()
{
long a,i;
int count; while(cin>>a&&a)
{
count=0;

if(isSushu(a-2)==1)
count++; //2先特殊考虑

for(i=3;i<=a/2;i+=2)
if(isSushu(i)==0||isSushu(a-i)==0)
continue;
else
count++;

cout<<count<<endl;
}
return 0;
}
谢谢您的打赏,我的大英雄 ^_^
Thank you for your generosity, my big hero ^_^

更多内容请关注公众号「西小玛」