0%

北大 acm 2562 Primary Arithmetic 解题报告

Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 6276 Accepted: 2424

Description

Children are taught to add multi-digit numbers from right-to-left one digit at a time. Many find the “carry” operation - in which a 1 is carried from one digit position to be added to the next - to be a significant challenge. Your job is to count the number of carry operations for each of a set of addition problems so that educators may assess their difficulty.

Input

Each line of input contains two unsigned integers less than 10 digits. The last line of input contains 0 0.

Output

For each line of input except the last you should compute and print the number of carry operations that would result from adding the two numbers, in the format shown below.

Sample Input

123 456555 555123 5940 0

Sample Output

No carry operation.3 carry operations.1 carry operation.

题意:两个数相加需要进位的次数思路:用字符串输入,反向转化成整型,然后对应位置相加,如果出现大于9说明要进位,最后还原初值

代码
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
#include <iostream>
#include <string>

using namespace std;

void getNumber(char str[],int c[])
{
int i,len=strlen(str);

for(i=0;i<len;i++)
{
c[i]=str[len-1-i]-'0';
}
}

int main()
{
char a[11],b[11];
int n[11]={0},m[11]={0},i,len,num;

while(cin>>a>>b)
{
if(strcmp(a,"0")==0&&strcmp(b,"0")==0)
break;

num=0;

getNumber(a,n);
getNumber(b,m);

for(i=0;i<11;i++)
if(n[i]+m[i]>9)
{
n[i+1]+=(n[i]+m[i])/10;
n[i]=m[i]=0; //赋值为0
num++;
}

if(num==0)
cout<<"No carry operation."<<endl;

if(num==1)
cout<<num<<" carry operation."<<endl;

if(num>1)
cout<<num<<" carry operations."<<endl; //注意operations的单复数
}
return 0;
}
谢谢您的打赏,我的大英雄 ^_^
Thank you for your generosity, my big hero ^_^

更多内容请关注公众号「西小玛」