0%

北大 acm 1218 THE DRUNK JAILER 解题报告

Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 11798 Accepted: 7690

Description

A certain prison contains a long hall of n cells, each right next to each other. Each cell has a prisoner in it, and each cell is locked.
One night, the jailer gets bored and decides to play a game. For round 1 of the game, he takes a drink of whiskey,and then runs down the hall unlocking each cell. For round 2, he takes a drink of whiskey, and then runs down the
hall locking every other cell (cells 2, 4, 6, ?). For round 3, he takes a drink of whiskey, and then runs down the hall. He visits every third cell (cells 3, 6, 9, ?). If the cell is locked, he unlocks it; if it is unlocked, he locks it. He
repeats this for n rounds, takes a final drink, and passes out.
Some number of prisoners, possibly zero, realizes that their cells are unlocked and the jailer is incapacitated. They immediately escape.
Given the number of cells, determine how many prisoners escape jail.

Input

The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines contains a single integer between 5 and 100, inclusive, which is the number of cells n.

Output

For each line, you must print out the number of prisoners that escape when the prison has n cells.

Sample Input

25100

Sample Output

210

直接用暴力解决

代码如下

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
#include <iostream>

using namespace std;

int main()
{
int t,n,a[200]={0},i,sum,k;

cin>>t;

while(t--)
{
sum=0;
cin>>n;

for(i=1;i<=n;i++)
{
if(i%2==0) a[i]=1;
}

for(k=3;k<=n;k++)
for(i=1;i<=n;i++)
if(i%k==0)
if(a[i]==0)
a[i]=1;
else
a[i]=0;

for(i=1;i<=n;i++)
{
if(a[i]==0) sum++; //a[i]=0表示牢房开着,等于1表示牢房关闭
a[i]=0;
}

cout<<sum<<endl;
}

return 0;
}
谢谢您的打赏,我的大英雄 ^_^
Thank you for your generosity, my big hero ^_^

更多内容请关注公众号「西小玛」